Apps

How to install Viber on Linux Mint 19.1

Viber is a user-friendly cross-platform Voice over Internet Protocol instant messaging and video calling application for smartphones created by Viber Media. In this post, we are going to show you the method to install Viber on Linux Mint 19.1.

Viber for Desktop
Viber for Desktop

Viber featured

So the Viber main Features are:

  • Text, photo, sticker and emoticons messages
  • Group conversations
  • Call any Viber user for free with HD sound quality
  • Full sync between your mobile and your Linux
  • Seamlessly transfer calls between Viber Desktop and the Viber app with one click or tap
  • No registration, passwords or invitations required
  • Messages are shown on all devices

Install Viber on Linux Mint 19.1

First, install libcurl3:

$ sudo apt install libcurl3 -y

Now, download viber.deb file for Viber website:

$ wget https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb

After downloading, install viber:

$ sudo apt install Download/viber.deb -y

Example output:

$ sudo apt install /home/rasho/Downloads/viber.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'viber' instead of '/home/rasho/Downloads/viber.deb'
The following packages were automatically installed and are no longer required:
  libqt5opengl5 libqt5printsupport5
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  viber
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/97,8 MB of archives.
After this operation, 431 MB of additional disk space will be used.
Get:1 /home/rasho/Downloads/viber.deb viber amd64 7.0.0.1035 [97,8 MB]
Selecting previously unselected package viber.
(Reading database ... 271283 files and directories currently installed.)
Preparing to unpack .../home/rasho/Downloads/viber.deb ...
Unpacking viber (7.0.0.1035) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23install viber:+linuxmint4) ...
Setting up viber (7.0.0.1035) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...

To start Viber application you can either run:

$ /opt/viber/Viber

from your terminal or search your start menu:

Click on the Viber icon to start the Viber application.

Welcom to Viber Screen
Welcom to Viber Screen

That is all!

9 Comments

  1. Hello!
    Not working on my PC with Linux Mint 19.1
    message:

    sudo apt install Download/viber.deb -y
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package Download

    Please help me!
    Chess

  2. I get the following errors when I try the install command:


    user@MintBT3:~/Downloads$ sudo apt install viber.deb
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package viber.deb
    E: Couldn’t find any package by glob ‘viber.deb’
    E: Couldn’t find any package by regex ‘viber.deb’

  3. Gutman
    I get the following errors when I try the install command:
    gutman@gutman-Inspiron-7720 ~ $ /opt/viber/Viber
    Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory…
    Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory…
    Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory…
    Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory…
    qml: type=””
    qml: type=””
    QObject: Cannot create children for a parent that is in a different thread.
    (Parent is QObject(0x7fab7e441520), parent’s thread is QThread(0x2ddae40), current thread is QThread(0x3786dc0)

  4. Hey.
    I had same error
    “E: Unable to locate package Download”
    So, I just came to downloads folder andinstall it by clicking 2 times on the package.
    Viber appeared in menu’s applist, but whn I trying to run it it just doesn’t start. No error message, or whatsoever, just nothing happens.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Close